Skytap Portal (cloud.skytap.com) issues

Incident Report for Skytap

Resolved

This issue has been resolved, and the Skytap Portal Website (cloud.skytap.com) should be available again to all users.
Posted May 22, 2025 - 07:28 UTC

Identified

We have determined that the Skytap Portal Website (cloud.skytap.com) is experiencing page load failures or slow page loads as of 06:45 AM UTC 22 Thursday May 2025. We are currently investigating this issue.

We will provide an update within one hour.
Posted May 22, 2025 - 07:23 UTC

Investigating

We have received alerts which have informed us that the Skytap Portal Website (cloud.skytap.com) is experiencing some performance issues as of 06:45 AM UTC 22 Thursday May 2025. We are currently investigating this issue.

We will provide an update within one hour.
Posted May 22, 2025 - 07:11 UTC
This incident affected: Website (Portal (cloud.skytap.com)).